5.2.1.7 Lab – Viewing the Switch MAC Address Table Answers

Last Updated on January 28, 2019 by Admin

5.2.1.7 Lab – Viewing the Switch MAC Address Table Answers

Lab – Viewing the Switch MAC Address Table (Answers Version)

Answers Note: Red font color or Gray highlights indicate text that appears in the instructor copy only.

Topology

Addressing Table

Device Interface IP Address Subnet Mask Default Gateway
S1 VLAN 1 192.168.1.11 255.255.255.0 N/A
S2 VLAN 1 192.168.1.12 255.255.255.0 N/A
PC-A NIC 192.168.1.3 255.255.255.0 N/A
PC-B NIC 192.168.1.2 255.255.255.0 N/A

Objectives

Part 1: Build and Configure the Network

Part 2: Examine the Switch MAC Address Table

Background / Scenario

The purpose of a Layer 2 LAN switch is to deliver Ethernet frames to host devices on the local network. The switch records host MAC addresses that are visible on the network, and maps those MAC addresses to its own Ethernet switch ports. This process is called building the MAC address table. When a switch receives a frame from a PC, it examines the frame’s source and destination MAC addresses. The source MAC address is recorded and mapped to the switch port from which it arrived. Then the destination MAC address is looked up in the MAC address table. If the destination MAC address is a known address, then the frame is forwarded out of the corresponding switch port associated with that MAC address. If the MAC address is unknown, then the frame is broadcasted out of all switch ports, except the one from which it came. It is important to observe and understand the function of a switch and how it delivers data on the network. The way a switch operates has implications for network administrators whose job it is to ensure secure and consistent network communication.

Switches are used to interconnect and deliver information to computers on local area networks. Switches deliver Ethernet frames to host devices identified by network interface card MAC addresses.

In Part 1, you will build a multi-switch topology with a trunk linking the two switches. In Part 2, you will ping various devices and observe how the two switches build their MAC address tables.

Note: The switches used are Cisco Catalyst 2960s with Cisco IOS Release 15.0(2) (lanbasek9 image). Other switches and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and output produced might vary from what is shown in the labs.

Note: Make sure that the switches have been erased and have no startup configurations. If you are unsure contact your instructor.

Answers Note: Refer to the Answers Lab Manual for the procedures to initialize and reload devices.

Required Resources

2 Switches (Cisco 2960 with Cisco IOS Release 15.0(2) lanbasek9 image or comparable)

2 PCs (Windows 7 or 8 with terminal emulation program, such as Tera Term)

Console cables to configure the Cisco IOS devices via the console ports

Ethernet cables as shown in the topology

Note: The Fast Ethernet interfaces on Cisco 2960 switches are autosensing and an Ethernet straight-through cable may be used between switches S1 and S2. If using another model Cisco switch, it may be necessary to use an Ethernet crossover cable.

Part 1: Build and Configure the Network

Step 1: Cable the network according to the topology.

Step 2: Configure PC hosts.

Step 3: Initialize and reload switches as necessary.

Step 4: Configure basic settings for each switch.

  1. Configure device name as shown in the topology.
  2. Configure IP address as listed in Addressing Table.
  3. Assign cisco as the console and vty passwords.
  4. Assign class as the privileged EXEC password.

Part 2: Examine the Switch MAC Address Table

A switch learns MAC addresses and builds the MAC address table, as network devices initiate communication on the network.

Step 1: Record network device MAC addresses.

  1. Open a command prompt on PC-A and PC-B and type ipconfig /all. What are the Ethernet adapter physical addresses?
    PC-A MAC Address: ___________________________________________________________________
    PC-B MAC Address: ___________________________________________________________________
    Answers will vary.
  2. Console into switch S1 and S2 and type the show interface F0/1 command on each switch. On the second line of command output, what is the hardware addresses (or burned-in address [bia])?
    S1 Fast Ethernet 0/1 MAC Address: ______________________________________________________
    S2 Fast Ethernet 0/1 MAC Address: ______________________________________________________
    Answers will vary but from the example output below the S1 F0/1 MAC address is 0cd9.96d2.3d81 and the S2 F0/1 MAC address is 0cd9.96d2.4581.
    S1# show interface f0/1FastEthernet0/1 is up, line protocol is up (connected) Hardware is Fast Ethernet, address is 0cd9.96d2.3d81 (bia 0cd9.96d2.3d81) MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,<output omitted>S1#S2# show interface f0/1FastEthernet0/1 is up, line protocol is up (connected) Hardware is Fast Ethernet, address is 0cd9.96d2.4581 (bia 0cd9.96d2.4581) MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,<output omitted>S2#

Step 2: Display the switch MAC address table.

Console into switch S2 and view the MAC address table, both before and after running network communication tests with ping.

  1. Establish a console connection to S2 and enter privileged EXEC mode.
  2. In privileged EXEC mode, type the show mac address-table command and press Enter.
    S2# show mac address-table
    Even though there has been no network communication initiated across the network (i.e., no use of ping), it is possible that the switch has learned MAC addresses from its connection to the PC and the other switch.
    Are there any MAC addresses recorded in the MAC address table?____________________________________________________________________________________
    The switch may have one or more MAC addresses in its table, based on whether or not the students entered a ping command when configuring the network. The switch will most likely have learned MAC addresses through S1’s F0/1 switch port. The switch will record multiple MAC addresses of hosts learned through the connection to the other switch on F0/1.
    S2# show mac address-table          Mac Address Table——————————————-Vlan    Mac Address       Type        Ports—-    ———–       ——–    —– All    0100.0ccc.cccc    STATIC      CPU All    0100.0ccc.cccd    STATIC      CPU All    0180.c200.0000    STATIC      CPU All    0180.c200.0001    STATIC      CPU All    0180.c200.0002    STATIC      CPU All    0180.c200.0003    STATIC      CPU All    0180.c200.0004    STATIC      CPU All    0180.c200.0005    STATIC      CPU All    0180.c200.0006    STATIC      CPU All    0180.c200.0007    STATIC      CPU All    0180.c200.0008    STATIC      CPU All    0180.c200.0009    STATIC      CPU All    0180.c200.000a    STATIC      CPU All    0180.c200.000b    STATIC      CPU All    0180.c200.000c    STATIC      CPU All    0180.c200.000d    STATIC      CPU All    0180.c200.000e    STATIC      CPU

     All    0180.c200.000f    STATIC      CPU

     All    0180.c200.0010    STATIC      CPU

     All    ffff.ffff.ffff    STATIC      CPU

       1    0cd9.96d2.3d81    DYNAMIC     Fa0/1

       1    1cc1.de91.c35d    DYNAMIC     Fa0/1

    Total Mac Addresses for this criterion: 22

    S2#

    What MAC addresses are recorded in the table? To which switch ports are they mapped and to which devices do they belong? Ignore MAC addresses that are mapped to the CPU.
    ____________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________
    There may be multiple MAC addresses recorded in the MAC address table, especially MAC addresses learned through S1’s F0/1 switch port. In the example output above, the S1 F0/1 MAC address and PC-A MAC address are mapped to S2 F0/1.

    If you had not previously recorded MAC addresses of network devices in Step 1, how could you tell which devices the MAC addresses belong to, using only the output from the show mac address-table command? Does it work in all scenarios?________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________
    The output of the show mac address-table command shows the port that the MAC address was learned on. In most cases this would identify which network device the MAC address belongs to, except in the case of multiple MAC addresses associated to the same port. This happens when switches are connected to other switches and record all of the MAC addresses for devices connected to the other switch.

Step 3: Clear the S2 MAC address table and display the MAC address table again.

  1. In privileged EXEC mode, type the clear mac address-table dynamic command and press Enter.
    S2# clear mac address-table dynamic
  2. Quickly type the show mac address-table command again. Does the MAC address table have any addresses in it for VLAN 1? Are there other MAC addresses listed?___________________________________________________________________________________
    No. The student will most likely discover that the MAC address for the other switch’s F0/1 switch port has been quickly reinserted in the MAC address table.
    S2# show mac address-table          Mac Address Table——————————————-Vlan    Mac Address       Type        Ports—-    ———–       ——–    —– All    0100.0ccc.cccc    STATIC      CPU All    0100.0ccc.cccd    STATIC      CPU All    0180.c200.0000    STATIC      CPU All    0180.c200.0001    STATIC      CPU All    0180.c200.0002    STATIC      CPU All    0180.c200.0003    STATIC      CPU All    0180.c200.0004    STATIC      CPU All    0180.c200.0005    STATIC      CPU All    0180.c200.0006    STATIC      CPU All    0180.c200.0007    STATIC      CPU All    0180.c200.0008    STATIC      CPU

     All    0180.c200.0009    STATIC      CPU

     All    0180.c200.000a    STATIC      CPU

     All    0180.c200.000b    STATIC      CPU

     All    0180.c200.000c    STATIC      CPU

     All    0180.c200.000d    STATIC      CPU

     All    0180.c200.000e    STATIC      CPU

     All    0180.c200.000f    STATIC      CPU

     All    0180.c200.0010    STATIC      CPU

     All    ffff.ffff.ffff    STATIC      CPU

       1    0cd9.96d2.3d81    DYNAMIC     Fa0/1

    Total Mac Addresses for this criterion: 21

    S2#

    Wait 10 seconds, type the show mac address-table command, and press Enter. Are there new addresses in the MAC address table? __________________ Answers will vary. There may be.

Step 4: From PC-B, ping the devices on the network and observe the switch MAC address table.

  1. From PC-B, open a command prompt and type arp -a. Not including multicast or broadcast addresses, how many device IP-to-MAC address pairs have been learned by ARP?____________________________________________________________________________________
    Answers will vary. The ARP cache may have no entries in it, or it may have the gateway IP address to MAC address mapping.
    C:\Users\PC-B> arp -a
      Interface: 192.168.1.2 — 0xb

      Internet Address       Physical Address         Type
      192.168.1.1            30-f7-0d-a3-17-c1        dynamic
    C:\Users\PC-B>
  2. From the PC-B command prompt, ping PC-A, S1, and S2. Did all devices have successful replies? If not, check your cabling and IP configurations.
    ________________________________________________________________________________________________________________________________________________________________________
    If the network was cabled and configured correctly the answer should be yes.
  3. From a console connection to S2, enter the show mac address-table command. Has the switch added additional MAC addresses to the MAC address table? If so, which addresses and devices?________________________________________________________________________________________________________________________________________________________________________
    There may only be one additional MAC address mapping added to the table, most likely the MAC address of PC-A.
    S2# show mac address-table          Mac Address Table——————————————-Vlan    Mac Address       Type        Ports—-    ———–       ——–    —– All    0100.0ccc.cccc    STATIC      CPU All    0100.0ccc.cccd    STATIC      CPU

     All    0180.c200.0000    STATIC      CPU

     All    0180.c200.0001    STATIC      CPU

     All    0180.c200.0002    STATIC      CPU

     All    0180.c200.0003    STATIC      CPU

     All    0180.c200.0004    STATIC      CPU

     All    0180.c200.0005    STATIC      CPU

     All    0180.c200.0006    STATIC      CPU

     All    0180.c200.0007    STATIC      CPU

     All    0180.c200.0008    STATIC      CPU

     All    0180.c200.0009    STATIC      CPU

     All    0180.c200.000a    STATIC      CPU

     All    0180.c200.000b    STATIC      CPU

     All    0180.c200.000c    STATIC      CPU

     All    0180.c200.000d    STATIC      CPU

     All    0180.c200.000e    STATIC      CPU

     All    0180.c200.000f    STATIC      CPU

     All    0180.c200.0010    STATIC      CPU

     All    ffff.ffff.ffff    STATIC      CPU

       1    0021.700c.050c    DYNAMIC     Fa0/18

       1    0cd9.96d2.3d81    DYNAMIC     Fa0/1

       1    0cd9.96d2.3dc0    DYNAMIC     Fa0/1

       1    1cc1.de91.c35d    DYNAMIC     Fa0/1

    Total Mac Addresses for this criterion: 24

    S2#

    From PC-B, open a command prompt and retype arp -a. Does the PC-B ARP cache have additional entries for all network devices that were sent pings?____________________________________________________________________________________
    Answers may vary, but the ARP cache on PC-B should have more entries.

    C:\Users\PC-B> arp -a

    Interface: 192.168.1.2 — 0xb

      Internet Address      Physical Address      Type

      192.168.1.3           1c-c1-de-91-c3-5d     dynamic

      192.168.1.11          0c-d9-96-d2-3d-c0     dynamic

      192.168.1.12          0c-d9-96-d2-45-c0     dynamic

    C:\Users\PC-B>

Reflection

On Ethernet networks, data is delivered to devices by their MAC addresses. For this to happen, switches and PCs dynamically build ARP caches and MAC address tables. With only a few computers on the network this process seems fairly easy. What might be some of the challenges on larger networks?

_______________________________________________________________________________________

ARP broadcasts could cause broadcast storms. Because ARP and switch MAC tables do not authenticate or validate the IP addresses to MAC addresses it would be easy to spoof a device on the network.

Device Configs

Switch S1

S1#show running-config

Building configuration…

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname S1

!

boot-start-marker

boot-end-marker

!

enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2

!

no aaa new-model

system mtu routing 1500

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

ip address 192.168.1.11 255.255.255.0

!

ip default-gateway 192.168.1.1

ip http server

ip http secure-server

!

line con 0

line vty 0 4

password cisco

login

line vty 5 15

login

!

end

 

Switch S2

S2#show running-config

Building configuration…

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname S2

!

boot-start-marker

boot-end-marker

!

enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2

!

no aaa new-model

system mtu routing 1500

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

ip address 192.168.1.12 255.255.255.0

!

ip default-gateway 192.168.1.1

ip http server

ip http secure-server

!

line con 0

line vty 0 4

password cisco

login

line vty 5 15

login

!

end

0 0 votes
Article Rating
Subscribe
Notify of
guest
0 Comments
Inline Feedbacks
View all comments